⭐️⭐️⭐️⭐️⭐️ Arduino Bluetooth Plugin – Published By Tony Abou Zaidan

THE PLUGIN CONNECTS TO MULTIPLE DEVICES AT THE SAME TIME

This plugin now supports BLE GATT characteristics communication for BLE on Android, MacOS, iOS and UWP.

Keywords:

Unity, Bluetooth, Android, Arduino, Hc05, HC06, Plugin, esp32, mciro controllers, hc-05, hc-06, esp, hc-08, IOS, uwp, macos, hololense

Short Description:

THE PLUGIN CONNECTS TO MULTIPLE DEVICES AT THE SAME TIME

This plugin now supports BLE GATT characteristics communication for BLE on Android, MacOS, iOS and UWP.

Rating: ⭐️⭐️⭐️⭐️⭐️

Discount: None

Asset Title: Arduino Bluetooth Plugin

Publisher: Tony Abou Zaidan

Category: tools, input-management

More Details about this asset:

THE PLUGIN CONNECTS TO MULTIPLE DEVICES AT THE SAME TIME

This plugin now supports BLE GATT characteristics communication for BLE on Android, MacOS, iOS and UWP.

Supports :
iOS: BLE
Android: BLE, BluetoothClassic
MacOS: BLE, BluetoothClassic
Windows PC: Bluetooth Classic, USB Cable
UWP: Bluetooth Classic, BLE
if you have any feature suggestion, you can fill this form
This plugin will help you connect your unity game/app to your arduino robot/project,
to control it, transfer data between the arduino and bluetooth enabled MacOS/iOS/Android/Windows PC/UWP.
This plugin allows you to:
Connect iOS device to Arduino/Raspberry Pi via BLE
Connect MacOS PC/Laptop to Arduino/RPi via BLE and Bluetooth Classic
Connect Android to Arduino/RPI via BLE and Bluetooth Classic
Connect Windows PC to Arduino/RPI via Bluetooth Classic
Connect Windows PC to Arduino/RPI via USB Cable
This plugin has been tested with HC-05/06, ESP32 modules for bluetooth classic
and HC-08 for BLE
A tutorial is also provided in the plugin to help you use the code.

This plugin does not require Unity Plus

In case of any troubles, contact me on my email so i can assist you.

This plugin only requires .NET 4.x framework

Thank you for the support


PS.
Once you get the plugin, move the PLUGIN folder from “BluetoothAPI” folder to the main asset folder.


This plugin supports Unity 2018.3 and above.
It can be used with earlier version but the Windows Bluetooth Support may not function as expected

Leave a Reply